Requirements

Required minimum configuration

Weather Station is designed to work properly on WordPress version 4 or higher. In addition to this, it requires the following extensions and versions:

  • PHP 5.4 or greater;
  • cURL extension;
  • JSON extension;
  • iconv support.

Most of the hosting services have already this type of configuration and in most cases, installing Weather Station will not require any configuration changes. Nevertheless, to prevent Weather Station from not being 100% functional, if one of these prerequisites is not met, the following screen will be displayed when using the plugin:

 

Requirements warning screen

   Note that if you are using a version of PHP earlier than 5.4, you will not even see this screen. Instead, you will get the following error: Parse error: syntax error, unexpected T_USE, expecting T_FUNCTION in ...

In addition to these technical requirements, you must also ensure that the WordPress task scheduler is fully operational.

Recommended configuration

As with WordPress, it is recommended to use PHP 7 or greater, with support for https. But that’s up to you …