Community Support

[This post is marked as unsolved] Data does not update  

Page 1 / 2
  RSS
remember
(@remember)
Eminent Member

Good Morning,

I'm having a weird problem, my wordpress is hosted on altervista.org, whenever I close the page where shortcodes are published and wordpress, shortcodes are only updated if someone is online on the website, is it normal?

Sorry for the question, but I have already explained the problem and what Altervista told me was that it could be a plugin problem.

If I wanted to have the graphics the same are only updated if someone is online on the website.

This topic was modified 2 years ago by Pierre Lannoy
Quote
Posted : 05/11/2018 1:50 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello @remember!

That's absolutely true, and it's the normal operation mode of WordPress. And it's not a problem with Weather Station, all plugins and WordPress features have the same "problem"...   🙄 

Fortunately there are many methods to avoid this.  😊 

Hope it helps...

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 05/11/2018 2:25 pm
remember
(@remember)
Eminent Member
Posted by: Pierre Lannoy

Hello @remember!

That's absolutely true, and it's the normal operation mode of WordPress. And it's not a problem with Weather Station, all plugins and WordPress features have the same "problem"...   🙄 

Fortunately there are many methods to avoid this.  😊 

Hope it helps...

Hi, Pierre 

apparently the graphics seem to be working with cron-job, but I'll continue testing.

I have a question in request mode, which one do I choose? "Put", "Get", "Post" etc. The only problem is WU, I have an ID under test and the updates are very spaced in the WU.

ReplyQuote
Posted : 09/11/2018 1:02 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello @remember!

Good news it's working 🙂

For the request mode (sorry, it's a new feature which is not in my screenshot), it's obviously "GET" (the standard way to get a webpage).

For WU, as you may know, they have some problems and issues. So the "error" (the spaced updates) are not due to you nor the plugin. It's due to WU. But that's not really a big problem as (I don't know if you're aware of that) they're discontinuing their API in end of December... So maybe, in some weeks, nobody will continue to post data on WU.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 09/11/2018 8:22 am
remember
(@remember)
Eminent Member
Posted by: Pierre Lannoy

Hello @remember!

Good news it's working 🙂

For the request mode (sorry, it's a new feature which is not in my screenshot), it's obviously "GET" (the standard way to get a webpage).

For WU, as you may know, they have some problems and issues. So the "error" (the spaced updates) are not due to you nor the plugin. It's due to WU. But that's not really a big problem as (I don't know if you're aware of that) they're discontinuing their API in end of December... So maybe, in some weeks, nobody will continue to post data on WU.

Thank you for your response, I have to thank you for your work. Pierre, the plugin is fantastic, as I can translate it!
Well the WU, we'll see what will happen, thanks for sharing, they say that there will supposedly be the possibility of sending data for free, let's see what the molds will be!

ReplyQuote
Posted : 09/11/2018 8:12 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin
Posted by: remember
 

[...]they say that there will supposedly be the possibility of sending data for free, let's see what the molds will be!

Yes, we will see it. But I'm not very optimistic... 🙁

If you're happy with the plugin, don't hesitate to read my forum signature 😉

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 09/11/2018 8:18 pm
demanvannederland
(@demanvannederland)
Active Member

Hei!

Sorry for hijacking the thread but I think I had a similar issue. 

I started up my wp site yesterday (complete newbe here) and have the plugin running now. So far, I really like it! One issue though is that there seems to be "holes" in the data appearing on the site. While the site shows actual data (as texual valuest) when I am on my wp-site and logged in, my phone or other devices do not show the most recent data. I've tried the manual above, but I am not sure if that has worked yet. Any tips or suggestions?

ReplyQuote
Posted : 17/11/2018 7:11 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello !

Do you mean you have "holes" on data pushed on WeatherUnderground or on your site?
Could you tell me what method you're using for cron?

Thanks

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 17/11/2018 7:16 pm
demanvannederland
(@demanvannederland)
Active Member

Wow, thanks for getting back to me so fast! I'm using data from my Netatmo weather station. There's been no errors or omissions in the data there. I always see the most recent data now when running wordpress. But on another device the (textual only, graphs look fine) data is about an hour old or more, seems to be the last time I saved changes to the page in wp.

One thing I also thought is that my Netatmo station records every 5 minutes (19:01, 19:06, etc) but weather station shows data at :00, :05, :10, etc. Would that cause any problems?

To be perfectly honest I do not know what you mean by cron method (sorry..) 😥 😳 

ReplyQuote
Posted : 17/11/2018 7:35 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

You're welcome 😉

In the previously mentioned document (this one) there are 2 described methods. Have you implemented one of these? If not, you should do it. It's a sort of requirement to have a fully functional WordPress install (if you have less than, says, 10k visit per day). And as Weather Station stays on top of the WordPress cron, it is a necessity if you want it to work properly.

Once done, everything should be in order. 🙂

If it's not the case, we will investigate it more in depth.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 17/11/2018 8:06 pm
demanvannederland
(@demanvannederland)
Active Member

I see. I've done (and just redid) the first part of your description. So, I added the line to the wp-config file and uploaded it again. Then I created the cronjob as specified. I'll get back to you to see if it works or not 🙂

By the way, in the wp-cron.php file it does say "Defining DISABLE_WP_CRON as true and calling this file directly are
mutually exclusive and the latter does not rely on the former to work."

This post was modified 2 years ago by demanvannederland
ReplyQuote
Posted : 17/11/2018 9:13 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin
Posted by: demanvannederland

"Defining DISABLE_WP_CRON as true and calling this file directly are
mutually exclusive and the latter does not rely on the former to work."

Yes. And that's why the WP cron will be functional after this step. This is one of the "weaknesses" of WordPress.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 17/11/2018 9:54 pm
demanvannederland
(@demanvannederland)
Active Member

Allright, thanks again 🙂 I'm 99% sure the issue is now resolved. I've switched off the standard plugin my hosting uses for caching (Varnish server). I tried checking the appropriate box in the weather station plugin settings earlier, but that did not seem to change anything. But now all my text values are updating! And since cronjob is running properly I have not seen any "holes" either.

ReplyQuote
Posted : 17/11/2018 10:45 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Great news!

Hope you will like Weather Station...

PS: if you're happy with it, don't hesitate to follow the link in my signature 😉

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 17/11/2018 11:08 pm
remember
(@remember)
Eminent Member
Posted by: demanvannederland

Allright, thanks again 🙂 I'm 99% sure the issue is now resolved. I've switched off the standard plugin my hosting uses for caching (Varnish server). I tried checking the appropriate box in the weather station plugin settings earlier, but that did not seem to change anything. But now all my text values are updating! And since cronjob is running properly I have not seen any "holes" either.

Good night,

would it be possible to share your website link?

Thank you

ReplyQuote
Posted : 18/11/2018 12:58 am
Page 1 / 2

To participate, please connect first!