Community Support

[This post is marked as unsolved] Internationalization support is not installed.  

  RSS
greylockglass
(@greylockglass)
Active Member

Hello, Weather Station folks! Look like a lovely plugin, and I'm eager to try it out. I'm getting the error, "Internationalization support is not installed" on the main dashboard, though, so I can't get started.

I understand that my server requirements need to be met, but I do not know whether this is something that I can do, or something that I must request my web host to do. It's Dreamhost, which is a very, very popular host over here in the States, so I'm sure if it can be done, they're already doing it.

Thanks for anything you can do to point me in the right direction.

 

Very best regards—

JASON VELÁZQUEZ
Editor, The Greylock Glass
https://www.greylockglass.com
Planet Earth's Mightiest Podcast News Network
________________________________________

NEW!!!

???? LISTEN: Will Call #62: The Wolves roam CenterStage in DeLappe’s 2017 masterpiece

Quote
Posted : 12/11/2017 2:35 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello Jason.

I don't know how is the Dreamhost offer. But it is a "big" hoster so using internationalization is obviously possible...

First of all, this package is mainly named PHP intl. In you admin panel (for Dreamhost, not WordPress admin) you should have an menu/item/... to set your php version: there is a good chance that package activation is there.

I found an old article to do that with your php.ini file, but maybe is there now an option right from your admin panel...

I hope this helps!

Pierre

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 12/11/2017 1:01 pm
greylockglass
(@greylockglass)
Active Member

Thank you for your kind response, Pierre. I was able to upgrade my PHP to 7.0.24, which was a good start, I thought, because I read somewhere that internationalization comes standard with 7.0. Still no luck, though. Dreamhost no longer supports php.ini, but has instead moved to a phprc file, which supposedly works exactly the same, and there was already one at the root level of my domain, so THAT seemed like the solution. I added the necessary link to the PHP file, and STILL no success. I have put a support ticket in with Dreamhost to find out what my next step should be. I'll let you know what the solution ends up being if I find one, since quite a few Dreamhost customers are running WordPress sites. Thanks! Jason

ReplyQuote
Posted : 12/11/2017 7:27 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Impatient to know what Dreamhost has answered you. Keep me in touch...

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 12/11/2017 7:35 pm
greylockglass
(@greylockglass)
Active Member

Standard case of reading my message only as far as necessary to find any reason to say it's not their problem: "Supporting 3rd party installation and configurations are outside the scope of our support. I'm sorry about that. I recommend to contact the plugin developer for further support. However, we can help confirm if the extension is enabled correctly. Please respond back with the domain name If you would like us to check the PHP configuration. " Sigh...I've written them back. We'll see if they actually try to provide support. Thanks!

ReplyQuote
Posted : 13/11/2017 6:28 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello Jason! Do you have some news from Dreamhost?

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 14/11/2017 11:13 am
greylockglass
(@greylockglass)
Active Member

So, Pierre (and others who find themselves seeking possible solutions to the problem of webhost support for internationalization) I DO have some news! The answer ended up being that for my host, DreamHost, they do support it, but you need to include a line in your phprc file (used to be the php.ini file, now retired): extension=intl.so This file is usually in a folder called php in your home/user/ folder. If that folder doesn't exist, you can create it via FTP (or ssh), and create the file as well—note that there should be NO extension, such as .txt. It's just called phprc. I included that line, uninstalled the WordPress Weather Station plugin, reinstalled it, and then refreshed the PHP file, and the error message went away. I am now happily experimenting with the absolute coolest web-based meteorological app available. I may just have to get my own physical weather station to complete the picture! Thanks, all.

ReplyQuote
Posted : 14/11/2017 6:58 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

That's a great new o/ I hope you will find now with my plugin what you was looking for... Happy Weather !

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 14/11/2017 7:14 pm
Alberni Weather
(@alberni)
Eminent Member

Thanks for this article. I am having the same kind of problem. My hosting provider reports that intl is installed in php but it still doesn't work. I will keep working on it and try to report back to this thread once it is fixed.

ReplyQuote
Posted : 22/11/2017 7:36 am
Alberni Weather
(@alberni)
Eminent Member

I can report that even though it indicated in my software that the php extension was installed... the web host did still have to activate it. So if anyone comes across this message, definitely talk to your web host provider. Thank you to Pierre and Jason for the original post!

ReplyQuote
Posted : 22/11/2017 9:06 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Haha! Some hosting providers are definitely unprofessional. I can reassure you, you are unfortunately not the only one in this case. The main thing is that it works now... Have a good time with Weather Station 🙂

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 22/11/2017 11:24 am
greylockglass
(@greylockglass)
Active Member

Hello, Alberni Weather— I'm glad you were able to get your host to act. I've had to hold my breath and count to 10 and respond to their pre-packaged "solutions" in calm and measured tones and explain again, using fewer and fewer words and bullet points. Makes it even worse for some reason when the "technical support" representative sounds like he's 14-years-old.

ReplyQuote
Posted : 22/11/2017 3:01 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello all!

Since version 3.5.4, Weather Station can run (in degraded mode) if internationalization support is not installed... 🙂

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 25/06/2018 5:27 pm

To participate, please connect first!