Community Support

[This post is marked as unsolved] Space after shortcodes  

  RSS
Chris
(@zerog981)
Reputable Member 🇩🇪🇨🇭Editor

Sorry it's my third post today, but I'm currently improving my page...

When I insert a textual data shortcode an extra space is inserted after the value. I realized this because I want to put some values in brackets and there is an empty space right before the closing bracket. For instance the following shortcode (used in brackets) gives me the output shown in the screenshot:

([live-weather-station-livetextual device_id='yy:00:00:00:00:02' module_id='00:00:00:00:00:02' measure_type='cbi' element='measure_value' format='plain-text' fx='glow' color='#81d742' speed='2000'])

This may not be related to Weather Station so maybe you can give me a short feedback on what you think about it.

Thanks!

Chris

I like the cold weather. It means you get work done.

Quote
Posted : 30/01/2019 11:40 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Chris.

I confirm it's not coming from Weather Station.

As your site is not public, you will be alone to debug this... I recommend to verify the css applied on this item (with developers tools in your browser).

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 30/01/2019 11:55 am
SetMin
(@setmin)
Trusted Member

Not a problem of WS. This is working here. see screenshot

ReplyQuote
Posted : 30/01/2019 1:23 pm
Chris
(@zerog981)
Reputable Member 🇩🇪🇨🇭Editor

Yap, Pierre already pointed me towards the right direction, I think it has to do with the theme I use. I'll keep you posted. As far as Weather Station is concerned I consider it solved.

I like the cold weather. It means you get work done.

ReplyQuote
Posted : 30/01/2019 2:12 pm
Chris
(@zerog981)
Reputable Member 🇩🇪🇨🇭Editor

Ok, after (unsuccessfully) messing around with CSS  and other settings I now used a very basic WP installation with only the Weather Station plugin and guess what, issue appears there too...

The good thing now is, I can share a link to the testpage. I assume you used AJAX for your testing, with inline rendering it's (of course) working as expected?

Chris

This post was modified 4 months ago by Chris

I like the cold weather. It means you get work done.

ReplyQuote
Posted : 30/01/2019 3:08 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Arggghhhh. Let me get an eye on it....

 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 30/01/2019 3:35 pm
Chris liked
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Wowow! A very special and tricky bug - this one MUST have your name  🤣 

I found it. And it will be fixed in the 3.7.9 (released in less than 2 days now).

A huge thank you for the detection of this so special bug  🤗 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 30/01/2019 3:57 pm
SetMin and Chris liked
Chris
(@zerog981)
Reputable Member 🇩🇪🇨🇭Editor

Ha! Awesome 😆 I'm really feeling honoured now 😊 

Thank you for investigating this!

I like the cold weather. It means you get work done.

ReplyQuote
Posted : 30/01/2019 4:00 pm
SetMin liked
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Chris!

Version 3.7.9 is released. Could you confirm it solves this issue?

Thanks.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 01/02/2019 9:25 am
Chris
(@zerog981)
Reputable Member 🇩🇪🇨🇭Editor

Hi Pierre!

Thank you, the issue is resolved now 🍾  🍾 

I like the cold weather. It means you get work done.

ReplyQuote
Posted : 01/02/2019 6:01 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Cool. Thanks for the confirmation  😎 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 01/02/2019 6:14 pm
Chris liked

  
Working

To participate, please connect first!