Community Support

Problem with maps and graphs  

  RSS
Joseta
(@joseta)
New Member

Good afternoon,

I installed this fantastic plugin today on my WP website. The options and designs are beautiful! I'm creating the map and the graphs of my weather stations, but when I insert the shortcode in the page, this is not showing anything. I can't find the problem. I use the PHP 7.3 version. The widget in the right block it's working without issues. 

I have 5 stations added and all of these are using realtime.txt from Cumulus.

Thank you very much,

Regards!

Quote
Posted : 20/04/2020 4:06 pm
Gerhard Witteveen
(@gerhard)
Reputable Member 🇳🇱 🇧🇪 Editor

Hi @joseta,

Did you try (temporarily) disabling other Wordpress plugins?

Something else you could try, is changing the 'resources' settings in in WeatherStation>settings>system. I remember having to change settings there. Maybe change one setting at a time, and recheck.

Hope this helps!

Kind regards,

Gerhard

 

 

ReplyQuote
Posted : 22/04/2020 4:40 pm
Joseta
(@joseta)
New Member

Hello @gerhard

Thank you very much! Now it's working, but I detected another issue. I think that the data it's not saving, only when I'm on the webpage. The configuration for saving data is configured:

  • Data category: daily
  • Compilation mode: standard
  • Retention period: 5 weeks

I attached an example. I didn't access the webpage last days because I was working. Today I acceded and the graph is displaying data from the time that acceded. 

Thank you very much.

Regards.

ReplyQuote
Posted : 24/04/2020 11:29 am
Gerhard Witteveen
(@gerhard)
Reputable Member 🇳🇱 🇧🇪 Editor

Hi @joseta

Did you setup a Cron?  This will probably remedy this issue. There is an extensive help on setting up a Cron in this blogpost:

https://weather.station.software/blog/how-to-get-up-to-date-weather-data/

Regards,

Gerhard

 

ReplyQuote
Posted : 24/04/2020 12:04 pm
kclifton liked
Joseta
(@joseta)
New Member

Hello @gerhard

Yes, I created a cronjob at the time that I configured a few days ago. Now, I have reviewed the configuration an I detected an issue. I wrote "wp-cron" instead of "wp-cron.php". I think that now is ok.

Thank you very much!

 

ReplyQuote
Posted : 24/04/2020 2:06 pm
Gerhard Witteveen
(@gerhard)
Reputable Member 🇳🇱 🇧🇪 Editor

Hi @joseta

Well, that's great! It would be nice if you would  share your Weather-station powered website in the 'showcase' section of the community support page. Love to see the result!

Kind regards,

Gerhard

ReplyQuote
Posted : 24/04/2020 2:39 pm
lino80sa
(@lino80sa)
New Member

@joseta

Hi Joseta, I read your post and it seems that I too have the same problem. But I didn't understand how to solve it. The old graphs work https://www.cervignanometeowebcam.it/statistiche-mensili/
 then I made updates of various plug-ins and templates and the awesome icons disappeared and the new graphics are not displayed as on this page https://www.cervignanometeowebcam.it/t/

I've been looking for the solution for days.

I also tried to disable all plug-ins but nothing.

Could you please dedicate some of your time to me?

ReplyQuote
Posted : 12/05/2020 7:11 pm

To participate, please connect first!