Community Support

Picture and Video Modules missing from shortcode module lists  

  RSS
Bob Eckman
(@bobeckman)
Active Member

Hi Pierre,

I'm trying to add either a picture or timelapse video to the website. Under Manage Modules, I see both a Picture and Video module. However, none of the module drop-downs for generating shortcodes show either Picture or Video as an option. Am I missing something? My data is from Bloomsky and I'm running the latest version of Weather Station.

Bob Eckman

Quote
Posted : 28/05/2019 9:34 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Bob.

Sorry if it's unclear. You can find snapshot module in "current records" tab and timelapse module in "historical data". Both are the last icon of the selector line.

Do you get it?

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 28/05/2019 11:51 pm
Bob Eckman
(@bobeckman)
Active Member

Hi Pierre,

I don't believe snapshot and timelapse are showing. I've attached a doc with snips of the relevant screens. I note that on the Station screen it shows a base, 2 virtual and 4 modules. The modules listed under Manage Modules are [Computed], [Ephemeris], Station, Outdoor, Wind, Rain, Solar, Picture, Video. Should there be 6 modules? Hope this helps,

Bob Eckman

 

ReplyQuote
Posted : 31/05/2019 9:59 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello Bob!

Thank you so much for your screenshots. It helps me to see something strange... Could you tell me if you see the modules (video and picture) when you click on "Manage Modules"?

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 01/06/2019 11:56 am
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Bob...

Just found the issue. It will be fixed in version 3.8.8, released before the end of the weekend. 

Thanks to have detected it 😊 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 01/06/2019 12:46 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello!

Just released version 3.8.8. Could you tell me if it solves your issue?

Thanks.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 01/06/2019 3:16 pm
Bob Eckman
(@bobeckman)
Active Member

Hi Pierre,

On the Station list, I now see 6 outdoor modules under the Composition column. However, I still don't have icons for the snapshot or video under Current Records or Historical Data. Dashboard says I'm currently running 3.8.8.

Bob

ReplyQuote
Posted : 03/06/2019 5:40 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Bob.

That's really strange and I can see one single reason for that: the Bloomsky documentation is not up to date regarding the id they use (for mine, all is ok).

Do you know the Mac address of your station? It's a series of pairs of letters or numbers like 94:a1:a2:73:36:75 for example. Could you give me yours?
 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 03/06/2019 6:09 pm
Bob Eckman
(@bobeckman)
Active Member

Well, I can certainly understand the Bloomsky documentation issue. Here they are:

Storm: 40:ed:98:cf:de:1a

Sky: 44:2c:05:95:4a:73

ReplyQuote
Posted : 03/06/2019 6:58 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hey!

Good catch. None of these ids are referenced as Bloomsky's ids... I will release a fix in the next few days, I'll let you know as soon as it is available.

Thanks for the help, Bob.

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 03/06/2019 7:02 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hello Bob!

Just released version 3.8.9. Could you tell me if it's better? 🤔 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 07/06/2019 6:10 pm
Bob Eckman
(@bobeckman)
Active Member

Hi Pierre,

We're making progress. The current webcam picture is fixed. You can see it on my site, lmwx.info. Unfortunately, I don't see the video on the Historical tab.

Bob

ReplyQuote
Posted : 07/06/2019 6:40 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Hi Bob.

  • The current snapshot displays the last snapshot taken by the station (not a video, a picture). So it's normal.
  • Conversely, the timelapse is a video. It is an historical data as it is only published by your station when the day ends. Your station doesn't publish partial timelapses (i.e. for a day which is not ended). It's why time-lapse is in the "historical" tab.

Why the icon is not displayed may have many reasons. In general, you can't access historical data before 36 hours of collecting. But there must be other reason. What I suggest first is to wait a first full cycle (~36 hours) and reverify if the icon is or is not present.

 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 07/06/2019 7:52 pm
Bob Eckman
(@bobeckman)
Active Member

Hi Pierre,

I found the issue with the video. It IS on the historical data tab, but the icon is missing. I just happened to notice that there was room for another icon and it was clickable. The function works as it should. Thank you so much. 

Bob

ReplyQuote
Posted : 09/06/2019 5:01 pm
Pierre Lannoy
(@pierre-lannoy)
Member Admin

Cool. Great news it's working.

The missing icon is due to the fact you're using Font Awesome 4 (in Weather Station > Settings > System). It will be fixed in 3.8.10. In the mean time, you can use Font Awesome 5 (which the recommended version).

Thanks for the report 😉 

If you like Weather Station, please consider to make a review to help make it known. That would be the best way to thank me...

ReplyQuote
Posted : 10/06/2019 1:00 pm

  
Working

To participate, please connect first!