Community Support

Daily records seems to be recorded but daily graphs say "no data to display"  

  RSS
Alyre-C
(@alyre-c)
New Member

I managed to fix  a problem with the reading of the current records by over riding the crono wp setting and letting linux do it instead. Also fixed the internationalisation error by installing php intl. I have also selected in settings "daily and historical display" and see the list of parameters below this option. Under events I see no errors when "All Systems" is selected.

Here is the first two oldest log : 

EventTimeServiceStationMessage
  Logger 3.8.11
Event 1, Notice code 0
2021-11-29 16:27:54
19 hours ago (purge)
  Weather Collector 3.8.11
Event 2, Notice code 0
2021-11-29 16:32:03
19 hours ago
File Handler - RealtimeEcowitt-AlyreData retrieved.

I did a install/uninstall  of the plugin and in case the records were corrupted because of the first two issues mentioned above.

Here are the last 4  events that takes us up to the present at the time of this text.

  Weather Collector 3.8.11
Event 227, Notice code 0
2021-11-30 11:08:02
1 min ago
File Handler - RealtimeEcowitt-AlyreData retrieved.
  Weather Collector 3.8.11
Event 226, Notice code 0
2021-11-30 11:02:03
7 mins ago
File Handler - RealtimeEcowitt-AlyreData retrieved.
  Weather Collector 3.8.11
Event 225, Notice code 0
2021-11-30 10:57:03
12 mins ago
File Handler - RealtimeEcowitt-AlyreData retrieved.
  Weather Collector 3.8.11
Event 224, Notice code 0
2021-11-30 10:52:03
17 mins ago
File Handler - RealtimeEcowitt-AlyreData retrieved.

It is recording and displaying current data directly  checked again the actual realtime.txt file and my physical weather display console:

 Outdoor module  
 Outdoor (visible)
 30 November 2021, 11:08 am (3 mins ago)
 90 %  -2.3 °C  2.87 g/kg
 
However, it says "No data to display" when I try to do a daily line graph of temperature. I really don't know where to go next. I am running WP on a raspberry pi 4, using dietpi. The weather station is an Ecowitt 3500 with an Ecowitt GW1000 as a gateway and data collected by Cumulus MX running on another pi 3 sending data by FTP to WP and to the plugin as a reatime.txt file. Current data comes up fine, even the gauges like pressure.
 
Any ideas of what to check or modify ?
 
Thanks
Alyre
Quote
Posted : 30/11/2021 4:28 pm

To participate, please connect first!